[CSV Excise Tax Email] Incorrect Sales Rep Information

Incident Report for Nabis

Resolved

This incident has been resolved.
Posted Nov 23, 2022 - 17:43 PST

Monitoring

In an emailed communication to Brand Admins on the afternoon of 11/22/22 regarding Retailers with Overdue Excise Tax, several brand partners have reported that the "Associated Sales Rep" column contains incorrect sales representative names appearing in the attached downloads. We are investigating the root cause, and any other potential anomalies.

We apologize for the issue, and would be happy to provide an updated copy of this CSV to partners upon request.
Posted Nov 22, 2022 - 17:31 PST
This incident affected: Nabis Brand Web Application.