Degraded Performance: Inventory Counts
Incident Report for Nabis
Resolved
The issue regarding inventory presentation has been resolved. Thank you for your patience.
Posted Dec 15, 2022 - 13:50 PST
Update
The issue regarding inventory presentation has been resolved. Thank you for your patience.
Posted Dec 15, 2022 - 13:46 PST
Investigating
We have received reports from several brands regarding isolated inventory issues on the site on the order form -- we are actively investigating, and will keep the team posted. Thank you.
Posted Dec 15, 2022 - 12:57 PST
This incident affected: Nabis Brand Web Application and Nabis Retailer Web Application.